Gold Coins 分类: POJ 2015-06-10 15:04 16人阅读 评论(0) 收藏

2023-02-16,,,

Gold Coins

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 21767   Accepted: 13641

Description

The king pays his loyal knight in gold coins. On the first day of his service, the knight receives one gold coin. On each of the next two days (the second and third days of service), the knight receives two gold coins. On each
of the next three days (the fourth, fifth, and sixth days of service), the knight receives three gold coins. On each of the next four days (the seventh, eighth, ninth, and tenth days of service), the knight receives four gold coins. This pattern of payments
will continue indefinitely: after receiving N gold coins on each of N consecutive days, the knight will receive N+1 gold coins on each of the next N+1 consecutive days, where N is any positive integer.

Your program will determine the total number of gold coins paid to the knight in any given number of days (starting from Day 1).

Input

The input contains at least one, but no more than 21 lines. Each line of the input file (except the last one) contains data for one test case of the problem, consisting of exactly one integer (in the range 1..10000), representing
the number of days. The end of the input is signaled by a line containing the number 0.

Output

There is exactly one line of output for each test case. This line contains the number of days from the corresponding line of input, followed by one blank space and the total number of gold coins paid to the knight in the given
number of days, starting with Day 1.

Sample Input

10
6
7
11
15
16
100
10000
1000
21
22
0

Sample Output

10 30
6 14
7 18
11 35
15 55
16 61
100 945
10000 942820
1000 29820
21 91
22 98
意思就是国王第一天能得到一个金币,接下来两天每天能得到两个金币,以此类推,计算金币的总数
#include <cstdio>
#include <cmath>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#include <iostream> using namespace std; int main()
{
int n;
while(~scanf("%d",&n)&&n!=0)
{
int sum=0;
int ans=1;
for(int i=1;i<=n;)
{
for(int j=1;j<=ans&&i<=n;j++,i++)
{
sum+=ans;
}
ans++;
}
printf("%d %d\n",n,sum);
}
return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

Gold Coins 分类: POJ 2015-06-10 15:04 16人阅读 评论(0) 收藏的相关教程结束。

《Gold Coins 分类: POJ 2015-06-10 15:04 16人阅读 评论(0) 收藏.doc》

下载本文的Word格式文档,以方便收藏与打印。