周赛-The Number Off of FFF 分类: 比赛 2015-08-02 09:27 3人阅读 评论(0) 收藏

2023-05-13,,

The Number Off of FFF

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2813 Accepted Submission(s): 935

Problem Description

X soldiers from the famous “FFF army” is standing in a line, from left to right.

You, as the captain of FFF, decides to have a “number off”, that is, each soldier, from left to right, calls out a number. The first soldier should call “One”, each other soldier should call the number next to the number called out by the soldier on his left side. If every soldier has done it right, they will call out the numbers from 1 to X, one by one, from left to right.

Now we have a continuous part from the original line. There are N soldiers in the part. So in another word, we have the soldiers whose id are between A and A+N-1 (1 <= A <= A+N-1 <= X). However, we don’t know the exactly value of A, but we are sure the soldiers stands continuously in the original line, from left to right.

We are sure among those N soldiers, exactly one soldier has made a mistake. Your task is to find that soldier.

Input

The rst line has a number T (T <= 10) , indicating the number of test cases.

For each test case there are two lines. First line has the number N, and the second line has N numbers, as described above. (3 <= N <= 105)

It guaranteed that there is exactly one soldier who has made the mistake.

Output

For test case X, output in the form of “Case #X: L”, L here means the position of soldier among the N soldiers counted from left to right based on 1.

Sample Input

2

3

1 2 4

3

1001 1002 1004

Sample Output

Case #1: 3

Case #2: 3

简单题,注意细节

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <map>
#include <list>
#include <algorithm>
#define LL long long
#define RR freopen("output.txt","r",stdoin)
#define WW freopen("input.txt","w",stdout) using namespace std; const int MAX = 100100; int main()
{
int T;
int n,a,m;
int flag;
int w=1;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
flag=0;
for(int i=0;i<n;i++)
{
scanf("%d",&a);
if(flag)
{
continue;
}
if(i==0)
{
m=a+1;
}
else
{
if(m==a)
{
m++;
}
else
{
flag=i+1;
}
}
}
printf("Case #%d: ",w++);
if(flag)
{
printf("%d\n",flag);
}
else
{
printf("1\n");
}
} return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

周赛-The Number Off of FFF 分类: 比赛 2015-08-02 09:27 3人阅读 评论(0) 收藏的相关教程结束。

《周赛-The Number Off of FFF 分类: 比赛 2015-08-02 09:27 3人阅读 评论(0) 收藏.doc》

下载本文的Word格式文档,以方便收藏与打印。