HDU2577 How to Type 2016-09-11 14:05 29人阅读 评论(0) 收藏

2023-05-30,,

How to Type

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 6211    Accepted Submission(s): 2804

Problem Description

Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad
habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.

 

Input

The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.

 

Output

For each test case, you must output the smallest times of typing the key to finish typing this string.

 

Sample Input

3
Pirates
HDUacm
HDUACM

 

Sample Output

8
8
8 Hint The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8.
The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8
The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8

 

本题的意思如hint解释,就是求一段字符串打完需要多少步,记得结束后需保持小写(caps关闭),你有caps和shift两种操作

开dp[105][2]二维数组保存结果,dp[i][0]表示第位输完后保持小写状态,dp[i][1]表示第i位输完后保持大写状态

注意大写转小也是可以用shift的

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <stack>
#include <queue>
#include <algorithm>
using namespace std;
#define inf 0x3f3f3f3f int dp[105][2];
char s[105]; int main()
{
int o;
while(~scanf("%d",&o))
{
while(o--)
{
scanf("%s",&s);
int k=strlen(s);
memset(dp,0,sizeof(dp));
dp[0][1]=1;
for(int i=1; i<=k; i++)
{
if(s[i-1]>='a'&&s[i-1]<='z')
{
dp[i][0]=min(dp[i-1][0]+1,dp[i-1][1]+2);//前一位小写状态+字母,前一位大写状态+shift+字母
dp[i][1]=min(dp[i-1][0]+2,dp[i-1][1]+2);//前一位小写状态+字母+caps,前一位大写状态+shift+字母 }
else
{
dp[i][0]=min(dp[i-1][0]+2,dp[i-1][1]+2);//前一位小写状态+shift+字母,前一位大写状态+字母+caps
dp[i][1]=min(dp[i-1][0]+2,dp[i-1][1]+1);//前一位小写状态+caps+字母,前一位大写状态+字母
} } printf("%d\n",min(dp[k][0],dp[k][1]+1));
} } return 0;
}

 

HDU2577 How to Type 2016-09-11 14:05 29人阅读 评论(0) 收藏的相关教程结束。

《HDU2577 How to Type 2016-09-11 14:05 29人阅读 评论(0) 收藏.doc》

下载本文的Word格式文档,以方便收藏与打印。