[CISCO] 交换机间链路聚合端口聚合

2023-06-05,,

[CISCO] 交换机间链路聚合端口聚合

一、Introduction

端口通道( port channel ) 是一种聚合多个物理接口 ( that ) 创建一个逻辑接口。你可以捆扎( bundle ) 八个单独的活动链接到一个信道端口,以提供更高的带宽冗余。端口通道也负载平衡这些物理接口上的通信量。只要端口通道中的至少一个物理接口可操作,端口通道就可以保持运行。——摘自: Configuring a Port Channel

二、Prerequisites

CISCO PACKET Tracer Student 6.2

三、Configure channel-group

interface FastEthernet0/7
channel-group 1 mode desirable
switchport mode trunk
!
interface FastEthernet0/8
channel-group 1 mode desirable
switchport mode trunk

Info:上述内容是使用 show running-config 查询到的结果。下文将 Step By Step 讲解。

First:Enter Into Interfaces

Switch#enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#interface faste
Switch(config)#interface fastethernet 0/7-8
^
% Invalid input detected at '^' marker.
Switch(config)#interface range fastethernet 0/7-8

Notice:注意进入接口时,需要使用 range 选项配合 num-num 写法。

Second:Setting VLAN Trunk

Switch(config-if-range)#switchport mode trunk

Info:Trunk 的概念可以简单理解为一个平台,方便俩岸的商人们进行交易。——推荐:VLAN、TRUNK 和 VTP 简介

Third:Setting channel-group Mode

Switch(config-if-range)#channel-group 1 mode desirable

Notice:以上指令需要在俩台交换机间都完整执行指令,而并非单台完整(这不是服务!)。

四、channel-group Model

以下为完整摘录,EtherChannel (PAgP and LACP) 以太通道。

Port Aggregation Protocol (PAgP)

PAgP 是 Cisco 專有,只能在 Cisco Switch 上設定,PAgP 有兩個模式,分別是 Desirable 與 Auto,兩隻使用 PAgP 的 Switch 就像一對等待對方表白的男女,只要有其中一方開口表白就可以走在一起。願意開口表白的一方叫 Desirable,等待對方表白的一方叫 Auto,所以兩隻 Switch 只要最少有一方是 Desirable 就可成 EtherChannel。因為 Desirable 一方會主動傳送出 PAgP Message,並要求對方回應。但如果雙方也設成 Auto,則雙方都是被動,就不可能成 EtherChannel 了。當 PAgP 成功建立 EtherChannel 後,PAgP Message 會繼續定時傳送去維持 EtherChannel。

Desirable Auto
Desirable
Auto

設定方法亦不難,只要用 channel-group 1 mode desirable 來設 Desirable Mode 和用 channel-group 1 mode auto 來設 Auto Mode 即可。

SW1(config)#interface range ethernet 0/0 - 1
SW1(config-if-range)#channel-group 1 mode desirable
Creating a port-channel interface Port-channel 1 SW1(config-if-range)#
SW2(config)#interface range ethernet 0/0 - 1
SW2(config-if-range)#channel-group 1 mode auto
Creating a port-channel interface Port-channel 1 SW2(config-if-range)#

Link Aggregation Control Protocol (LACP)

至於 LACP 是 IEEE Standard,玩法與 PAgP 大致相同,只不過把兩個 Mode 的名稱由 Desirable 改成 Active 以及由 Auto 改成 Passive。所以,只要最少有一邊是 Active,EtherChannel 就成立。

Active Passive
Active
Passive
SW1(config)#interface range ethernet 0/0 - 1
SW1(config-if-range)#channel-group 1 mode active
Creating a port-channel interface Port-channel 1 SW1(config-if-range)#
SW2(config)#interface range ethernet 0/0 - 1
SW2(config-if-range)#channel-group 1 mode passive
Creating a port-channel interface Port-channel 1 SW2(config-if-range)#

不過 LACP 多了一個叫 Hot Standby 的功能,就是除了 8 個 Port 設成 EtherChannel 之外,還可以最多把 8 個 Port 加進去做 Hot Standby Port。Hot Standby Port 的意思是當有 Active Port 因為某些原因 Down 時,Hot Standby Port 可以即時補上,所以,LACP 最多可以容納 16 port (8 個 Active + 8 個 Hot Standby) 在一個 EtherChannel 之中。至於那個 Port 會被選擇成為 Active 則會按 Port Priority 決定,LACP 會先選 Port Priority 較小的做 Active,如 Port Priority 相同則選 Port ID 較小的。請看以下例子:

假設現時有 16 個 Port 在同一個 EtherChannel,由於所有 Port Priority 預設都是 32768,因此系統選擇 Port ID 最小的 8 個 Port 成為 Active Port,其他則成為 Hot Standby。

SW1#show etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use N - not in use, no aggregation
f - failed to allocate aggregator M - not in use, no aggregation due to minimum links not met
m - not in use, port not aggregated due to minimum links not met
u - unsuitable for bundling
d - default port w - waiting to be aggregated
Number of channel-groups in use: 1
Number of aggregators: 1 Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) LACP Et0/0(P) Et0/1(P) Et0/2(P)
Et0/3(P) Et1/0(P) Et1/1(P)
Et1/2(P) Et1/3(P) Et2/0(H)
Et2/1(H) Et2/2(H) Et2/3(H)
Et3/0(H) Et3/1(H) Et3/2(H)

現在嘗試把一些 Port 的 LACP Port Priority 變小,Active Port 亦隨之改變。留意兩隻 Switch 相對的 Port 的狀態必需相同 (我這邊是 Active Port,對方也應該是 Active Port),否則會造成不相容而出現 Secondary Aggregator 的問題。

SW1(config)#int range ethernet 2/0-1, ethernet 3/2-3
SW1(config-if-range)#lacp port-priority 1000
SW1(config-if-range)#end
SW1#show etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use N - not in use, no aggregation
f - failed to allocate aggregator M - not in use, no aggregation due to minimum links not met
m - not in use, port not aggregated due to minimum links not met
u - unsuitable for bundling
d - default port w - waiting to be aggregated
Number of channel-groups in use: 1
Number of aggregators: 1 Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) LACP Et0/0(P) Et0/1(P) Et0/2(P)
Et0/3(P) Et1/0(H) Et1/1(H)
Et1/2(H) Et1/3(H) Et2/0(P)
Et2/1(P) Et2/2(H) Et2/3(H)
Et3/0(H) Et3/1(H) Et3/2(P)
Et3/3(P)

五、Connectivity testing

Switch#show etherchannel ?
load-balance Load-balance/frame-distribution scheme among ports in port-channel
port-channel Port-channel information
summary One-line summary per channel-group
<cr>
Switch#show etherchannel port-channel
.....
Ports in the Port-channel: Index Load Port EC state No of bits
------+------+------+------------------+-----------
0 00 Fa0/7 Desirable-Sl 0
0 00 Fa0/8 Desirable-Sl 0
Time since last port bundled: 00d:03h:15m:36s Fa0/8

[CISCO] 交换机间链路聚合端口聚合的相关教程结束。

《[CISCO] 交换机间链路聚合端口聚合.doc》

下载本文的Word格式文档,以方便收藏与打印。